R6 Message Net banner
1 - 12 of 12 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
To start I have an 03 with full Yoshimira Exhaust and K&N air filter. I have only had the bike for a month or two. I havent laid it down since I have owned it. Also, all the valves are in spec along with cam timing is correct.

I had to take the motor apart to replace the driveshaft because most of the threads for the sprocket nut had been stripped. The bike ran fine before the work and it worked fine after....for about two weeks. It ran fine on Friday and I didnt ride it all weekend and Monday came around and it was hard to start but I got it going even though it almost wouldnt hold an idle.

Once I let it warm up I started to take off and noticed that it wouldnt want to go past 2,000 RPM unless you gave it alot of gas and slipped the clutch. (Has the same problem even in neutral). Well after changing spark plugs, oil, and filter and even pouring in some Red Line Fuel Injector cleaner it still has the same problems. The exhaust seems to be muffled and not loud and crisp like it used too.

I ran the diagnostic and got codes 13, 15, 21, 22, and 30. I tried a test of clearing all the codes to see if any would go away and if any would stay and guess what they all went away. Great so I started the bike again....it now idles better but the surging around 2,000 RPM is worse and it jerks alot more like it is sputtering. I check all my connections, no lines seemed to be kinked. And I am now stuck.

If any one has any input please let me know, if not I will have to take it in to a mechanic next week. I have run out of ideas as this is my first bike and I am not sure on what is going on. I am just ready to get it running right so I can enjoy the nice weather. Thank you everyone for any help you have.
 

·
N*gga stole my bike!
Joined
·
183 Posts
I was experiencing the same issues with my recently purchased 03 R6 as well. Just dropped her off at my local dealer to have the recall work done. They are taking care of the ignition coil recall as well as the drive sprocket recall. I miss her terribly already.
 

·
N*gga stole my bike!
Joined
·
183 Posts
did you have to pay to have the dealer do the recall? i heard they are charging now. correct me if i'm wrong, thanks.
The first dealer I checked with said that they were charging now, so I tried another local dealer and they didn't mention charging me for it, so I think I am in the clear. If not, I was provided with a number for Yamaha, and I can commence my bitching in order to get it done free of charge.
 

·
N*gga stole my bike!
Joined
·
183 Posts
so this is only for 03's not 05's right?
Well, certain years qualify for certain recalls.

For the ignition coil recall, it just states that it affects all YZF-R6R(C) models, not VIN or year specification. A good way to verify would be to lift your tank and see if your bike is equipped with Denso coils. If so, then you should be able to get them replaced with the Mitsubishi coils. But I think that issue was resolved for 04+ models.

The other one you may want to consider is the Drive Sprocket recall. This one affects the following VIN ranges:

99-05 YZF-R6
RJ04E-0000015~0028429
RJ06E-0000012~0030477
RJ04Y-0000006~0002931
RJ06Y-0000004~0006432


Just call up the dealer and ask them to check to see if there are any recalls on your bike. They'll ask you to provide them with the VIN and they can see for you.
 
1 - 12 of 12 Posts
Top