R6 Message Net banner
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So one day suddenly my bike lost throttle response on the high way. It didn't shut off but i could give it full throttle and it would barely sputter. i would have to kick it down into neutral, turn the key off, then back on, start it up and quickly kick it back up into gear before i got rear ended. All the way home this happened every 5 minutes or so...This was after a long day of riding and the next day it never happened. Seems it happens when i ride for long. Also when i sit in traffic for a while or even a a light thats long it sometimes shuts off and the battery sounds like its dead. sometimes takes a while to start back up. The battery is new this season so im thinking its something else. i dont know much about the electrical side of bikes so any help would be appreciated. I also dont have much cash so if there is a way i could avoid taking it in and getting RAPED on labor that would be great...in my research people mention rectifiers or stators? i know nothing about them so i wouldnt know how to test or even locate one...Please any feedback would help.

**2005 Yamaha R6**
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
BTW..i have just about 20,000 miles on the bike and every once and a while the check engine light goes on and off around when these problems occur. If there's any other details i left out please ask. Spark Plugs? ReJetted? Stator? Rectifier? AHHH
 

·
Registered
Joined
·
117 Posts
BTW..i have just about 20,000 miles on the bike and every once and a while the check engine light goes on and off around when these problems occur. If there's any other details i left out please ask. Spark Plugs? ReJetted? Stator? Rectifier? AHHH
Start by pulling the engine code ..
Could be a number of things (maybe fuel related) ..
A shop wouldn't charge much to check the code, or just
find someone who has the diagnostic tester and get them to
check the error code ..
 
1 - 6 of 6 Posts
Top