R6 Message Net banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
So fuel pump works outside the tank when all hooked up, when I install it into tank and put gas it doesn’t work, but while being out of tank I poured gas into the pump and bike fire up? Any help would be nice
 

·
Registered
Joined
·
1 Posts
Hi, I recently went through this. drove me nuts. I eliminated the connectors, both inside the pump canister and on the harness. I found the fuel pump will torque as it starts and the connectors get loose. They are actually pretty poor quality. Bike runs strong now. I ran the wires through holes that I drilled where the connectors go and sealed with marine epoxy.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Hi, I recently went through this. drove me nuts. I eliminated the connectors, both inside the pump canister and on the harness. I found the fuel pump will torque as it starts and the connectors get loose. They are actually pretty poor quality. Bike runs strong now. I ran the wires through holes that I drilled where the connectors go and sealed with marine epoxy.
So similar to me, needed to re wire the green connector, the wire inside snapped, I picked up a 2004 r6 with 23.9k miles on it, whoever had it before me had not a clue what they were doing re did the entire bike how did we post pictures it’s prettt sweet
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Have plenty of fairings, rearsets, etc if anyone needs something. Fun fact for the gas tank fuel pump seal, can use the o ring out of a Porsche oil filter. It seals better and lasts longer forgot the exact part number for it but also gives seals that fit the fuel pump along with the pressure return spout
 
1 - 5 of 5 Posts
Top