R6 Message Net banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Im not very good at working on bikes but my 99 R6 is in the shop and they cant seem to fix it. My bike set for a year and the carbs were clogged so i took it to the shop. They cleaned my carbs and syncd them , plugs and coils were replaced, got an oil change and my airfilter was clean. when i got the bike back it was running really rich and missing badly in the lower gears. It missed really bad when i got on the throttle. I took it back to the mechanic and he said the bike needed to be rejetted so they did that and the bike ran fine in the lower gears until i hit the throttle hard and it still was missing and then it started cutting out after 11000 RPMs like that was the rev limiter. I took it back and it was the CDI box that was bad which made my plugs go bad again. He changed the CDI box and changed the plugs again and he just called me and said it seemed like the CDI box went bad again and it was doing the same thing to him. My 99 R6 has a full 2 brothers racing exhaust, a [email protected] airfilter, and a 50 tooth sprocket. I know that the [email protected] is not good for carbuerated bikes but it has had it in there since i bought it and ran fine. I told the mechanic to switch to the stock air filter and he tried it and it was still running crappy. I Hope someone can help because im tired of paying this dude for nothing. Thanx for anyone that helps because im clueless and i want to start riding again.
 

·
Registered
Joined
·
10,715 Posts
I think you need a new shop.. it sounds like they're just taking your money dude.

Missing and cutting out could be the coils or a vacuum leak from not putting it back together right. How did he test the CDI? Why did you get new coils? It was running fine before, why did it need to be rejetted??
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
they replaced the coils because they said they were bad after it had sat for a year without being ridden. The bike wouldnt start or anything before all the work had been done. Then i go and pick the bike up and i noticed it running really rich like it was getting too much gas or something. I took it back and they said it needed to be rejetted and they did that and it ran better in the lower gears but bogged down at 11000 RPMS and so i took it back for the 3rd time and the CDI box was bad. I dont know how he tested it but he said it was bad. It just seems that the bike has no power anymore. The shop said they have done everything and have checked everything twice and they are starting to act clueless but they probably didnt put something back together right. Thanx for the help and ill ask them if they checked the vacuum leak or not. Thanks again
 

·
#1 member
Joined
·
2,807 Posts
I second the new shop suggestion. a real shop should be able to diagnose the problem without telling you to buy a bunch of stuff in hope that fixes it.
sounds like they have no clue.
personally, I would put money on the carbs being dirty etc still. how on earth did they tune the bike when it is still running poorly? they didn't. because they don't know how.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
thanks for the opinions. I went and picked my bike up today because like you all said they dont know what there doing and charging me for shit that isnt fixing the problem. When i picked it up i had him write down everything they did so here it is : new CDI box, cleaned the carbs with ultra sonic cleaner, re jetted it 3 times, 10 sets of spark plugs and new coils. The dude told me that a wire or something could be pinched or that my [email protected] might be bad. But before he told my that he switched to a stock air filter and it still rode like shit so im about clueless and moneyless with this bike. He also said that the timing or something could be off. Im gonna go ahead and order a stock airfilter and put it in and see what happens and i guess have one of my buddies at work look at the bike. Thanks again for the input.
 

·
Registered
Joined
·
10,715 Posts
:lol the timing could be off :wtf???? Those guys have no clue.. 10 sets of plugs and they rejetted 3x??? Gah!

Good luck man. It really doesnt sound like any kind of major problem, just needs a little know how.

Where do you live? (fill out your profile)
 

·
Registered
Joined
·
2 Posts
OMG...that sounds horrible...i think those guys at that shop know very little, ecxept how to spend YOUR money. I too have a problem, and i dont want a shop to touch it (here in Canada - Alberta the shop rate is $90/hr!).
 

·
Registered
Joined
·
1 Posts
OMG...that sounds horrible...i think those guys at that shop know very little, ecxept how to spend YOUR money. I too have a problem, and i dont want a shop to touch it (here in Canada - Alberta the shop rate is $90/hr!).
Our costs for bike repairs here in Pennsylvania =$100 - $110 per hr!!
 
1 - 9 of 9 Posts
Top